Pajero 4WD Club of Victoria Public Forum Pajero 4WD Club of Victoria Public Forum

Go Back   Pajero 4WD Club of Victoria Public Forum > Vehicles > Challenger > PB -PC Challenger 2009 - 2014

PB -PC Challenger 2009 - 2014 Covering 2.5 HP diesel

Reply
 
Thread Tools Display Modes
  #1  
Old 27-07-16
AJS AJS is offline
Junior Member
 
Join Date: Nov 2007
Location: Adelaide
Posts: 3
Angry 4WD Dash lights flashing (Top 2)

I hope someone might be able to give me some advice?

I have a 2011 Diesel manual and the 2 bottom drive dash lights are green and top 2 lights are flashing green all of the time, regardless of selecting 2WD or 4WD.

2WD drives fine, 2 bottom light are green and top 2 lights are flashing.

4H will not engage and seems to slip, there is no drive to front and rear wheels 2 bottom light are green and top 2 lights are flashing.

4L will engage and drive in 4WD, 2 bottom light are green and top 2 lights are flashing.

Appreciate your thoughts on what could be causing the problem.
Alan
Reply With Quote
  #2  
Old 27-07-16
BMN BMN is offline
Valued Member
 
Join Date: Jul 2010
Location: Perth WA
Posts: 549
Default

My first check would be the actuator vacuum lines at the front diff. The actuator hangs under the front diff housing on the right hand side. Make sure the black, approx 8mm air lines are attached and in good nik.
__________________
2010 PB LS Auto, 7seat, silver with lots of pinstripes, Dual batts, Toyo AT2, ARB roof rack, Rear storage/fridge, Bilstien/Kings
Reply With Quote
  #3  
Old 28-07-16
AJS AJS is offline
Junior Member
 
Join Date: Nov 2007
Location: Adelaide
Posts: 3
Default

Thanks for the suggestion, will have a good look.
Reply With Quote
  #4  
Old 28-07-16
Toddyh Toddyh is offline
Valued Member
 
Join Date: Nov 2013
Location: Lalor Park, NSW
Posts: 665
Default

Obviously this is for a Pajero but the same principle applies.
http://4wd.blogeasy.com/article.view...ticleID=318776

As has been mentioned it's often to do with the vacuum solenoid or hoses. It could also be a sticky actuator due to lack of use (of 4wd).
__________________
2010 PB LS- ARB Bull Bar, Runva 11XP winch, Cooper ST Maxx 265/70/17, Ultimate suspension lift, Bushskinz plates, Kaymar rear bar with single wheel carrier.
Reply With Quote
  #5  
Old 28-07-16
nj swb's Avatar
nj swb nj swb is offline
Resident
 
Join Date: Jun 2007
Location: Adelaide
Posts: 5,867
Default

I believe it's an issue with the switches on your transfer case.

Your Challenger has a good old fashioned mechanical selector for low range, so there's no pesky electrickery to get in the way. Wherever you put the lever, that's what the transfer is doing.

In 4H the front disconnector is open, so the centre diff is sending most drive to the front diff, which in turn is sending power to the disconnected right axle. This could be an actuator problem as suggested above, but that wouldn't explain why the front lights flash in 2H.

It's the switches on the transfer that detect what the transfer is doing, and tell the front actuator what to do. If the switches have problems the system doesn't know what the transfer is doing, and doesn't know what to do in response.

In addition to checking the vacuum lines, you could try
1. Check voltage at the solenoids in the different modes, to see if they're getting the right electrical signals.
2. Jack the front right wheel of the ground, engine idling, and try to spin it in the different modes. It should spin free in 2H, but not in any of the 4wd modes.
__________________
NT Platinum. DiD Auto with 265/70R17 Toyo MT, Lift, Lockers, Lockup Mate, 3.15 gears, LRA Aux tank, bullbar, winch, lights, lots of touring stuff. Flappy paddles. MMCS is gone!

Project: NJ SWB. 285/75R16 ST Maxx, 2" OME suspension, 2" body lift, ARB 110, 120l tank, bullbar, scratches, no major dents. Fully engineered in SA. NW DiD & auto in place - a long way to go....

Scorpro Explorer Box
Reply With Quote
  #6  
Old 28-07-16
AJS AJS is offline
Junior Member
 
Join Date: Nov 2007
Location: Adelaide
Posts: 3
Default

Appreciate all the information, will check on Saturday.
Reply With Quote
  #7  
Old 09-12-19
littleriver's Avatar
littleriver littleriver is offline
Valued Member
 
Join Date: Jan 2013
Location: Queensland
Posts: 3,296
Default

Quote:
Originally Posted by AJS View Post
Appreciate all the information, will check on Saturday.
Mine just started doing it .. what was the out come ?

...
__________________
2012 PB Challenger LS (Manual) - OZtec shocks front & rear with King Springs (lift 2 inch) , 22 inch front #plate light bar, roof racks & basket, Bridgestone Duelers 697 LT A/T,Dash cam, 2 way radio 80 channel, Ipod connected via glove box usb, Waeco cf50, Garmin gps (with topo), Opticoat + paint protection, Nilrust proofing, Roosystems Ecu Remap
Reply With Quote
  #8  
Old 09-12-19
itsamitsi's Avatar
itsamitsi itsamitsi is offline
Valued Member
 
Join Date: Aug 2015
Location: Hervey Bay Queensland
Posts: 592
Default

Must be the time for it. My rear drive indicators flicker and carry on. May be a shitty switch?
__________________
Paul 2015 PC Challenger LS Auto - 2" Ultimate lift, Bridgie Dueller M/T 674, catch can and resistor mod, Custom MCC Bullbar ,12000lb winch , Dual batteries ,Boo's Bash plates ,E-Drive throttle controller,Auto Mate, In car entertainment and more.
Reply With Quote
  #9  
Old 10-12-19
littleriver's Avatar
littleriver littleriver is offline
Valued Member
 
Join Date: Jan 2013
Location: Queensland
Posts: 3,296
Default

Quote:
Originally Posted by itsamitsi View Post
Must be the time for it. My rear drive indicators flicker and carry on. May be a shitty switch?
Last night put it through all the 4wd ranges ... started this morning all clear for now .. time will tell ...

...
__________________
2012 PB Challenger LS (Manual) - OZtec shocks front & rear with King Springs (lift 2 inch) , 22 inch front #plate light bar, roof racks & basket, Bridgestone Duelers 697 LT A/T,Dash cam, 2 way radio 80 channel, Ipod connected via glove box usb, Waeco cf50, Garmin gps (with topo), Opticoat + paint protection, Nilrust proofing, Roosystems Ecu Remap
Reply With Quote
  #10  
Old 12-12-19
westvic westvic is offline
Junior Member
 
Join Date: May 2016
Location: Ballarat
Posts: 7
Default

Went through this recently (PC 2015 manual with 150k)

Got under the vehicle, unplugged and cleaned the connections on the side of the transfer case(?) and no more problems with flashing lights

Never seemed to have a problem with being in the correct gear, just the lights flashed sometimes then came good after a while
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY - Pajero Flashing 4x4 Dash lights 4ePikanini Generation 2 Pajero 10 06-04-19 07:24 AM
Intermittent flashing of dash 4wd lights paulor1069 Generation 4-1 Pajero 2 08-10-12 08:11 PM
4WD lights on dash flashing. scubaseven Generation 2 Pajero 17 11-02-12 02:44 PM
flashing dash lights post gearbox removal blaggon Generation 3 Pajero 8 01-09-10 01:11 PM
Dash lights flashing, MM dealer has no solution Patagonia Generation 3 Pajero 4 25-08-10 07:19 AM


All times are GMT +10. The time now is 11:47 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.