Pajero 4WD Club of Victoria Public Forum Pajero 4WD Club of Victoria Public Forum

Go Back   Pajero 4WD Club of Victoria Public Forum > Vehicles > Generation 3 Pajero

Generation 3 Pajero NM - NP Models 2000 - 2006

Reply
 
Thread Tools Display Modes
  #1  
Old 10-06-15
sheep sheep is offline
Junior Member
 
Join Date: Aug 2013
Location: Perth
Posts: 5
Default Issue with gear selection - auto NP

Noticed recently that when pushing the gear stick from Drive to Manual Select nothing happens; no green lights displaying what gear it's in on the dash and moving the stick up and down doesn't change gears whilst driving.

Works normally in drive but no green light next to Drive either, not sure if it's always been like this but I used to be able to change gears by shifting.

Everything else works fine, 4wd select and Drive/Neutral/Reverse but selection mode is totally dead.

Any ideas?
Reply With Quote
  #2  
Old 10-06-15
MatthewP MatthewP is offline
Valued Member
 
Join Date: Jul 2014
Location: North of Brisbane
Posts: 452
Default

The shifter mechanism is electronic, so my guess is that one of the switches that activate manual selection is playing up.

I cant help with specifics, I just remember that the switching is electronic from reading a thread about changing the direction the manual shifter worked.
ie. Stock is forward is up a gear and backwards is down, swapping the wires between the switches makes Forward change down a gear and backwards change up.

Matt
__________________
05 NP Pajero Platinum 3.2DID Auto
Reply With Quote
  #3  
Old 13-06-15
MatthewP MatthewP is offline
Valued Member
 
Join Date: Jul 2014
Location: North of Brisbane
Posts: 452
Default

Have you checked the Auto Transmission fuse in the fusebox in the engine bay?

Matt
__________________
05 NP Pajero Platinum 3.2DID Auto
Reply With Quote
  #4  
Old 13-06-15
vladguan's Avatar
vladguan vladguan is offline
Valued Member
 
Join Date: Mar 2015
Location: Adelaide
Posts: 2,573
Default

Does the D light go off when you shift across? AFAIK there are 3 switches, one to detect when you shift across and back. Two more for gear changes. If the D light goes off then I would pressume it is detecting the shift across. There is a fuse supplyimg power to it, fuse 3 in the Junction box in cabin. When you shift across, and then drive, does it auto change gears as if it is still in auto mode? I doubt it is fuse 3 issue as it is a multi purpose fuse. Like wise fuse 23 in engine bay.
Reply With Quote
  #5  
Old 17-06-15
sheep sheep is offline
Junior Member
 
Join Date: Aug 2013
Location: Perth
Posts: 5
Default

D light goes off as soon as it goes into Drive, I have lights for everything else, operates normally in Drive then when I slide across nothing changes, no lights on 12345 and still changes gears as if it's in auto.

Will check out the fuses...
Reply With Quote
  #6  
Old 17-06-15
vladguan's Avatar
vladguan vladguan is offline
Valued Member
 
Join Date: Mar 2015
Location: Adelaide
Posts: 2,573
Default

Quote:
Originally Posted by sheep View Post
D light goes off as soon as it goes into Drive, I have lights for everything else, operates normally in Drive then when I slide across nothing changes, no lights on 12345 and still changes gears as if it's in auto.

Will check out the fuses...
Are you saying that the D light goes out when you shift into tiptronic?
Reply With Quote
  #7  
Old 17-06-15
sheep sheep is offline
Junior Member
 
Join Date: Aug 2013
Location: Perth
Posts: 5
Default

So there's a green light next to Park, Neutral and Reverse but it goes out as soon as I put it into Drive, no difference shifting into tiptronic, car changes gears normally either way.
Reply With Quote
  #8  
Old 17-06-15
vladguan's Avatar
vladguan vladguan is offline
Valued Member
 
Join Date: Mar 2015
Location: Adelaide
Posts: 2,573
Default

Hmm, OK, interesting.

I am assuming the switch to detect when it is in D and tiptronic is not working as the TCU knows you are in D via the inhibitor switch C-05. Your D light may just be out coincidentally.

Following is the circuit diagram for the shift switch assembly:
http://faq.out-club.ru/download/paje...E01CC00ENG.pdf

Following is the diagram shwing the location of D-119 and D-139 connectors:
http://faq.out-club.ru/download/paje...926AC00ENG.pdf

What I would do is get to D-119 (D-139 is easier to get to but you can't test that as the ground is on the other side of the D-119 connector). Put the red probe of a multimeter on pin #4 of D-119 and ground the black probe and then shift across and back to see if you get a reading and also do it for selecting up and down. They terminals of the shift switch assembly may just be corroded.

As mentioned before, I doubt it is faulty fuses as otherwise the whole A/T ECU will be having issues.
Reply With Quote
  #9  
Old 18-06-15
vladguan's Avatar
vladguan vladguan is offline
Valued Member
 
Join Date: Mar 2015
Location: Adelaide
Posts: 2,573
Default

If you have a clamp type multimeter or can borrow one then it is easier to check at the D-139 connector which sits under/behind the glove box. Just clamp it over the R-B wire into pin 3 and shift between sports and auto modes to see if there is a reading. The fact that it is not going to sports mode means there shouldn't be a reading.
Reply With Quote
  #10  
Old 20-06-15
sheep sheep is offline
Junior Member
 
Join Date: Aug 2013
Location: Perth
Posts: 5
Default

Couldn't find 139 but took off the central console and found 119 I think. Found a black wire that had been chewed through.. Tried for about an hour to get it out of the white harness thing but no joy, had a tiny screwdriver in the back but it wouldn't budge.

In the end I twisted it together and wrapped it in insulation tape working fine for now at least. I have the drive green light back and selection works.

Thanks mate.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can a scangauge be used to show gear selection and lockup status? TC.Barky Generation 4-3 Pajero 2 18-11-14 04:19 AM
Auto gear selection lights Bobos73 Generation 3 Pajero 8 26-03-14 10:21 AM
Fuel eco test between auto and manual gear selection. Goodsy Generation 4-1 Pajero 35 27-02-14 01:26 PM
Difficult gear selection, then turn into a 4 speed. wasarangie PB -PC Challenger 2009 - 2014 2 19-09-13 03:59 PM
No gear selection after re main seal fix.. Help!! PajeroNewbie Generation 2 Pajero 4 24-07-10 10:10 PM


All times are GMT +10. The time now is 02:11 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.