Pajero 4WD Club of Victoria Public Forum Pajero 4WD Club of Victoria Public Forum

Go Back   Pajero 4WD Club of Victoria Public Forum > Vehicles > Challenger > PB -PC Challenger 2009 - 2014

PB -PC Challenger 2009 - 2014 Covering 2.5 HP diesel

Reply
 
Thread Tools Display Modes
  #1  
Old 13-05-19
Stu125's Avatar
Stu125 Stu125 is offline
Junior Member
 
Join Date: Apr 2015
Location: ACT
Posts: 14
Default Diesel fuel question

Hi guys
I have a 2011 Challenger Diesel
Recently I have noticed a lot of black fuel smoke when accelerating and towing
It seems very excessive to me so I took it to a local diesel specialist and they had it for a few days and ran all sorts of test and road tests and couldn't fault it!
They checked the fuel, pump, injectors and EGR and everything came up ok


It shows up more at night when you have lights behind but it seems excessive!
Even with the trailer on with only a couple of 100kg of wood under light throttle there is the fuel type smoke!

Any ideas on anything I can try?


Cheers
__________________
2011 Challenger 2.5TD Standard so far!
Reply With Quote
  #2  
Old 13-05-19
old Jack's Avatar
old Jack old Jack is offline
Valued Member
 
Join Date: Jun 2011
Location: Adelaide
Posts: 6,600
Default

Quote:
Originally Posted by Stu125 View Post
Hi guys
I have a 2011 Challenger Diesel
Recently I have noticed a lot of black fuel smoke when accelerating and towing
It seems very excessive to me so I took it to a local diesel specialist and they had it for a few days and ran all sorts of test and road tests and couldn't fault it!
They checked the fuel, pump, injectors and EGR and everything came up ok


It shows up more at night when you have lights behind but it seems excessive!
Even with the trailer on with only a couple of 100kg of wood under light throttle there is the fuel type smoke!

Any ideas on anything I can try?


Cheers

Hi Stu,


Try the following to see if this helps.

Clean the MAF sensor.
Fit an EGR delete resistor or electronic delete unit.


OJ.
__________________
2011 PB Base White Auto, Smartbar, Cooper STMaxx LT235/85R-16,TPMS, HR TB, 3 x Bushskinz, front +40mm Dobinson , rear +50mm EHDVR Lovells, Dobinson MT struts and shockers, Peddars 5899 cone springs, Windcheater rack, GME UHF, Custom alloy drawer system inc. 30lt Engel & 2 x 30 AH LiFePo batteries + elec controls, Tailgate hi-lift/long struts, Nightbreaker +130LB & Phillips +100 HB, Lightforce 20" single row driving beam LED lightbar, Scanguage II.
MM4x4 Auto Mate, Serial No 1 .
Reply With Quote
  #3  
Old 13-05-19
Lakey's Avatar
Lakey Lakey is offline
Senior Member
 
Join Date: Apr 2012
Location: Brisbane
Posts: 312
Default

Mine was doing the same but the smoke was more white than black I think just looked dark. Again mainly noticeable at night with lights behind. My fuel consumption was creeping up a bit also. I was figuring it was over fuelling.

After the last service it no long does it and the consumption has dropped again. So whatever they did seems to have fixed it. I'm thinking they have done a relearn to reset the fuel use.
__________________
Cheers
Lakey

2012 PB Challenger LS manual. White, tinted windows, MM towbar, Rhino Aero Sportz Bars, otherwise pretty much bog standard.
Reply With Quote
  #4  
Old 13-05-19
old Jack's Avatar
old Jack old Jack is offline
Valued Member
 
Join Date: Jun 2011
Location: Adelaide
Posts: 6,600
Default

Quote:
Originally Posted by Lakey View Post
Mine was doing the same but the smoke was more white than black I think just looked dark. Again mainly noticeable at night with lights behind. My fuel consumption was creeping up a bit also. I was figuring it was over fuelling.

After the last service it no long does it and the consumption has dropped again. So whatever they did seems to have fixed it. I'm thinking they have done a relearn to reset the fuel use.
Hi Lakey,

If you had the service through a Dealer a Service Department, then they should have done a "small injector relearn". From time to time the engine does this of its own accord but I do not know how often or what triggers an "auto small injector relearn"

OJ.
__________________
2011 PB Base White Auto, Smartbar, Cooper STMaxx LT235/85R-16,TPMS, HR TB, 3 x Bushskinz, front +40mm Dobinson , rear +50mm EHDVR Lovells, Dobinson MT struts and shockers, Peddars 5899 cone springs, Windcheater rack, GME UHF, Custom alloy drawer system inc. 30lt Engel & 2 x 30 AH LiFePo batteries + elec controls, Tailgate hi-lift/long struts, Nightbreaker +130LB & Phillips +100 HB, Lightforce 20" single row driving beam LED lightbar, Scanguage II.
MM4x4 Auto Mate, Serial No 1 .
Reply With Quote
  #5  
Old 13-05-19
itsamitsi's Avatar
itsamitsi itsamitsi is offline
Valued Member
 
Join Date: Aug 2015
Location: Hervey Bay Queensland
Posts: 570
Default

Mines never had an SQL done in just coming up to 100K and my fuel usage has remained pretty much the same. Smoke appears to be the same too.
__________________
Paul 2015 PC Challenger LS Auto - 2" Ultimate lift, Bridgie Dueller M/Ts, catch can and resistor mod, Custom MCC Bullbar ,12000lb winch , Dual batteries ,Boo's Bash plates ,E-Drive throttle controller,Lock up mate, In car entertainment and more.
Reply With Quote
  #6  
Old 16-05-19
Stu125's Avatar
Stu125 Stu125 is offline
Junior Member
 
Join Date: Apr 2015
Location: ACT
Posts: 14
Default

Thanks guys

I will try the MAF clean and see how it goes

Cheers
__________________
2011 Challenger 2.5TD Standard so far!
Reply With Quote
  #7  
Old 17-05-19
BMN BMN is offline
Valued Member
 
Join Date: Jul 2010
Location: Perth WA
Posts: 549
Default

Quote:
Originally Posted by Stu125 View Post
Thanks guys

I will try the MAF clean and see how it goes

Cheers
Have had similar black smoke times over the years and yes MAF first up, then oil change, fuel filter and she's back on track. 220k, self serviced since 30k no SQL,s no issues.
__________________
2010 PB LS Auto, 7seat, silver with lots of pinstripes, Dual batts, Toyo AT2, ARB roof rack, Rear storage/fridge, Bilstien/Kings
Reply With Quote
  #8  
Old 15-06-19
Stu125's Avatar
Stu125 Stu125 is offline
Junior Member
 
Join Date: Apr 2015
Location: ACT
Posts: 14
Default

Hi guys
Quick update for you
I cleaned the MAF and disconnected the Battery for a while and OMG what a difference

I did the same trip away last weekend with my camper and there was bugger all sign of smoke at all!!!
The car ran like a dream!

Even got 12.9L/100 towing my camper with 5 in the car!!!

Thanks for the advise!!!! You saved me from disliking my car and selling it
__________________
2011 Challenger 2.5TD Standard so far!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Diesel oil dipstick question mckenzl Generation 4-1 Pajero 10 19-12-15 12:00 PM
pre heating turbo diesel question spiezzy Generation 2 Pajero 1 21-03-11 08:51 PM
NH Turbo Diesel Question and Problem spiezzy Generation 2 Pajero 7 14-11-10 08:07 PM
2.8 Diesel Question lostincable Generation 3 Pajero 5 16-05-10 09:01 AM
diesel motor question sharky Mechanical 2 16-08-08 04:44 PM


All times are GMT +10. The time now is 04:45 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.