Pajero 4WD Club of Victoria Public Forum Pajero 4WD Club of Victoria Public Forum

Go Back   Pajero 4WD Club of Victoria Public Forum > Vehicles > Challenger > PB -PC Challenger 2009 - 2014

PB -PC Challenger 2009 - 2014 Covering 2.5 HP diesel

Reply
 
Thread Tools Display Modes
  #1  
Old 25-02-19
AndyP100 AndyP100 is offline
Junior Member
 
Join Date: Feb 2019
Location: Yattalunga
Posts: 9
Default Challenger Stuttering at 2000 rpm

Hi, New to this forum.
I have a 2011 Challenger that I have just bought a couple of weeks ago, and it seems to be stuttering a bit at about 1600 to 2000 rpm when holding the accelerator steady or accelerating. At first I wondered if I was just not keeping the revs up enough but I am getting more convinced that it is a fault. Just wondering if anyone has had this problem before or has any Ideas.

Regards
Andrew
Reply With Quote
  #2  
Old 25-02-19
old Jack's Avatar
old Jack old Jack is online now
Valued Member
 
Join Date: Jun 2011
Location: Adelaide
Posts: 6,620
Default

Hi Andrew

Welcome.

Manual or auto trans?
What gear are you in?
Speed?
How many kms on the Odometer?

OJ.
__________________
2011 PB Base White Auto, Smartbar, Cooper STMaxx LT235/85R-16,TPMS, HR TB, 3 x Bushskinz, front +40mm Dobinson , rear +50mm EHDVR Lovells, Dobinson MT struts and shockers, Peddars 5899 cone springs, Windcheater rack, GME UHF, Custom alloy drawer system inc. 30lt Engel & 2 x 30 AH LiFePo batteries + elec controls, Tailgate hi-lift/long struts, Nightbreaker +130LB & Phillips +100 HB, Lightforce 20" single row driving beam LED lightbar, Scanguage II.
MM4x4 Auto Mate, Serial No 1 .
Reply With Quote
  #3  
Old 25-02-19
AndyP100 AndyP100 is offline
Junior Member
 
Join Date: Feb 2019
Location: Yattalunga
Posts: 9
Default

Don't know if I needed to mention that it's a diesel
Reply With Quote
  #4  
Old 25-02-19
AndyP100 AndyP100 is offline
Junior Member
 
Join Date: Feb 2019
Location: Yattalunga
Posts: 9
Default

Hi Jack. It's a manual and it seems to happen in most gears if it is at about that engine speed. If I put my foot down it fairly quickly clears up as the revs go up. Today I noticed it at about 60kph in 3rd which doesn't seem to slow for that gear?
Reply With Quote
  #5  
Old 25-02-19
AndyP100 AndyP100 is offline
Junior Member
 
Join Date: Feb 2019
Location: Yattalunga
Posts: 9
Default

It's got about 130000km on the clock.
Reply With Quote
  #6  
Old 25-02-19
littleriver's Avatar
littleriver littleriver is online now
Valued Member
 
Join Date: Jan 2013
Location: Queensland
Posts: 3,242
Default

Just a few starters

Have you checked the airfilter?

Also check your MAF sensor .. you may have to by some pressure pack cleaner (crc)

3rdly when was the fuel filter last changed ?

...
__________________
2012 PB Challenger LS (Manual) - OZtec shocks front & rear with King Springs (lift 2 inch) , 22 inch front #plate light bar, roof racks & basket, Bridgestone Duelers 697 LT A/T,Dash cam, 2 way radio 80 channel, Ipod connected via glove box usb, Waeco cf50, Garmin gps (with topo), Opticoat + paint protection, Nilrust proofing, Roosystems Ecu Remap
Reply With Quote
  #7  
Old 26-02-19
old Jack's Avatar
old Jack old Jack is online now
Valued Member
 
Join Date: Jun 2011
Location: Adelaide
Posts: 6,620
Default

When you say "stuttering", is it that if you hold the accelerator pedal steady with the engine rpm between 1600 and 2000rpm does the engine rpm flucuate, is so by how much? or does it feel more like a flat spot/dead zone?

Does it do it in the same rpm range when you are both gently acceleration through the rpm range and decelerating through the rpm range as well as when you hold the rpm within the range of 1600-2000 rpm.

Does it do it when the engine is cold or hot or both?

Does it get worse or better if going up or downhill?

When was the last time the engine was serviced by a MItsubisi dealer?

What does the service history look like?

OJ.
__________________
2011 PB Base White Auto, Smartbar, Cooper STMaxx LT235/85R-16,TPMS, HR TB, 3 x Bushskinz, front +40mm Dobinson , rear +50mm EHDVR Lovells, Dobinson MT struts and shockers, Peddars 5899 cone springs, Windcheater rack, GME UHF, Custom alloy drawer system inc. 30lt Engel & 2 x 30 AH LiFePo batteries + elec controls, Tailgate hi-lift/long struts, Nightbreaker +130LB & Phillips +100 HB, Lightforce 20" single row driving beam LED lightbar, Scanguage II.
MM4x4 Auto Mate, Serial No 1 .
Reply With Quote
  #8  
Old 26-02-19
AndyP100 AndyP100 is offline
Junior Member
 
Join Date: Feb 2019
Location: Yattalunga
Posts: 9
Default

Thanks for the replies.

I haven't checked the filters yet. It has a perfect service history but when I bought it only a few weeks ago, it had been in the dealers for about 6 months.

The stuttering i am referring to is a bit like you would get in a petrol car if it was misfiring or just missing if you were in too high a gear, but you can be going along steady and it just does it. Not down hill but slightly more up hill. That's why at first I thought it was just me not being used to it and not changing down quick enough. I was wondering if it could be the EGR valve?
My thoughts are that if it was a fuel filter it should struggle more when accelerating than at a low steady speed.
Any idea what speed/gear combinations are too high?
Sometimes it is chugging along at 1200 rpm happily.
Reply With Quote
  #9  
Old 26-02-19
nj swb's Avatar
nj swb nj swb is offline
Resident
 
Join Date: Jun 2007
Location: Adelaide
Posts: 5,573
Default

Probably a complete red herring, but it sounds a little like the issue I had when my NT Pajero was new (to me) - on cruise control on the highway, hit a slight rise and the engine felt like it was misfiring, just before the torque converter unlocked.

I reported it to Mitsubishi when I had them check it over just after I bought it, and they applied a transmission software update that fixed the problem.

I severely doubt that a Challenger would have the same issue (different engine and transmission) - but you never know? Perhaps ask Mitsubishi to confirm that all recalls / updates have been applied?
__________________
NT Platinum. DiD Auto with 265/70R17 Toyo MT, Lift, Lockers, Lockup Mate, 3.15 gears, LRA Aux tank, bullbar, winch, lights, lots of touring stuff. Flappy paddles. MMCS is gone!

Project: NJ SWB. 285/75R16 ST Maxx, 2" OME suspension, 2" body lift, ARB 110, 120l tank, bullbar, scratches, no major dents. Fully engineered in SA. NW DiD & auto in place - a long way to go....

Scorpro Explorer Box
Reply With Quote
  #10  
Old 26-02-19
old Jack's Avatar
old Jack old Jack is online now
Valued Member
 
Join Date: Jun 2011
Location: Adelaide
Posts: 6,620
Default

The PB/PC Challenger has had several software up dates but I do not think this is the issue. To diagnose this problem the car needs to be connected to a MUT III and have all the sensors involved in the engine control checked for correct operation and calibration. This should be done before replacing any parts or major disassembly as an incorrect signal from a sensor could be causing the problem.

The fact that at RPMs below 1,600 and above 2,000 there is not a reported problem and the problem is worse when the engine and driveline are underload, and in all gears at speeds where the rpm is between 1,600 and 2,000rpm lead me to suspect it might be the variable inlet guide vane control of the turbo charger not working correctly.
Just an educated guess based on info supplied.

OJ.
__________________
2011 PB Base White Auto, Smartbar, Cooper STMaxx LT235/85R-16,TPMS, HR TB, 3 x Bushskinz, front +40mm Dobinson , rear +50mm EHDVR Lovells, Dobinson MT struts and shockers, Peddars 5899 cone springs, Windcheater rack, GME UHF, Custom alloy drawer system inc. 30lt Engel & 2 x 30 AH LiFePo batteries + elec controls, Tailgate hi-lift/long struts, Nightbreaker +130LB & Phillips +100 HB, Lightforce 20" single row driving beam LED lightbar, Scanguage II.
MM4x4 Auto Mate, Serial No 1 .
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Urgent help wont start 2000 pa challenger t-rex1995 PA Challenger 1998 - 2006 5 20-09-13 12:10 AM
Lurching/stuttering phil C Mechanical 4 27-11-10 03:10 PM
2000 NM Slight Vibration @2000-2300 rpm Pete1000 Mechanical 1 26-04-10 08:44 PM
slight vibration NM 2000 Auto Petrol 2000 rpm Pete1000 Generation 3 Pajero 3 11-04-10 01:12 PM
Roofrack for 2000 challenger mark_05 Bolted on bits, factory and aftermarket accessories 7 13-09-08 07:32 PM


All times are GMT +10. The time now is 02:38 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.