Pajero 4WD Club of Victoria Public Forum Pajero 4WD Club of Victoria Public Forum

Go Back   Pajero 4WD Club of Victoria Public Forum > Vehicles > Generation 4-1 Pajero

Generation 4-1 Pajero NS Model 2006 - 2009

Reply
 
Thread Tools Display Modes
  #1  
Old 1 Week Ago
Sonic Sonic is offline
Member
 
Join Date: Apr 2015
Location: Adelaide
Posts: 64
Default Voltage query on Dual battery RedArc Isolator

Iíve got a Dual battery system with the RedArc Smart start isolator and a Red Arc Dual battery monitor in my car
But I had my starter battery go flat, so I used the blue override to start my car (as itís designed to)
But now Iíve fitted a brand new starter battery, my battery monitor is reading 14v on the new battery (when driving ) but only 12v on the aux battery

It used to both read 14v (when driving ) and my aux battery is only 5months old

Any ideas ?
Reply With Quote
  #2  
Old 1 Week Ago
nj swb's Avatar
nj swb nj swb is offline
Resident
 
Join Date: Jun 2007
Location: Adelaide
Posts: 4,978
Default

I hope I'm wrong, but I think you might've killed the isolator (I did something similar with a similar product).

I believe the "over-ride" function is for when the starter battery hasn't quite got enough grunt, and the second battery "helps" - it might tip in an extra 100 Amps or so.

If the starter battery is REALLY flat (or stuffed e.g. dropped a cell) the second battery is doing the bulk of the starting - contributing maybe 300 - 400 Amps. I don't believe these isolators handle that scenario, and it kills them - the heat dissipated within the isolator is proportional to the square of the current, so 3 to 4 times the current is 10 to 15 times the heat (yes, I rounded - sue me! )

The fact that you have a brand new starter battery tells me that your old starter died, so your isolator probably was stressed by the "jump start".
__________________
NT Platinum. DiD Auto with 265/70R17 Toyo MT, Lift, Lockers, 3.15 gears, LRA Aux tank, bullbar, winch, lights, lots of touring stuff. Flappy paddles. MMCS is gone!

Project: NJ SWB. 285/75R16 ST Maxx, 2" OME suspension, 2" body lift, ARB 110, 120l tank, bullbar, scratches, no major dents. Fully engineered in SA. NW DiD & auto in place - a long way to go....
Reply With Quote
  #3  
Old 1 Week Ago
Sonic Sonic is offline
Member
 
Join Date: Apr 2015
Location: Adelaide
Posts: 64
Default

Sounds very much right tbh I just noticed it seems to look like itís working but the monitor in my car is only reading 12v on the aux battery side when the car is moving, not itís usual 14v and wonít the aux battery eventually go flat? If the isolator is stuffed?
Reply With Quote
  #4  
Old 1 Week Ago
Morville Morville is offline
Valued Member
 
Join Date: Mar 2008
Location: Buxton Vic
Posts: 729
Default

Is there a fuse or circuit breaker between either battery and the Redarc isolator?
Peter
Reply With Quote
  #5  
Old 2 Days Ago
Sonic Sonic is offline
Member
 
Join Date: Apr 2015
Location: Adelaide
Posts: 64
Default

Quote:
Originally Posted by Morville View Post
Is there a fuse or circuit breaker between either battery and the Redarc isolator?
Peter
100% correct , it had blown a 60amp fuse !!!
All changed and running sweet

Thanks again
Reply With Quote
  #6  
Old 2 Days Ago
XLS PB Challenger XLS PB Challenger is offline
Member
 
Join Date: May 2016
Location: Reynella East
Posts: 51
Default

Quote:
Originally Posted by Sonic View Post
100% correct , it had blown a 60amp fuse !!!
All changed and running sweet

Thanks again
Hi,

What size cable you using with the SBI12 between the two positive terminals ?

Cheers
Paul
__________________
2010 PB Challenger Auto - 265/70/17 BFG - MCC front bar - 9 inch LED kings spot lights- Safari Snorkel - 2 inch lift - REDARC BMS1230 Manager & REDARC TVMS - AUX battery in custom tray behind cargo trim - Jump start feature - 3inch Triton exhaust - morepower diesel chip - bash plates - 9.5 XP winch - Auto front locker - soon upgrade to automate.
Reply With Quote
  #7  
Old 2 Days Ago
Morville Morville is offline
Valued Member
 
Join Date: Mar 2008
Location: Buxton Vic
Posts: 729
Default

Quote:
Originally Posted by Sonic View Post
100% correct , it had blown a 60amp fuse !!!
All changed and running sweet

Thanks again
Hi Sonic, glad it is fixed. Unfortunately if you link the batteries via the Redarc to start the car particularly if the starter battery is nearly flat you will blow the 60 amp fuse every time.
Peter
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Redarc 1225D - do I still need a battery isolator NPS Generation 3 Pajero 10 2 Days Ago 03:06 PM
Redarc Dual Voltage monitor Sonic Generation 4-1 Pajero 3 25-07-16 07:51 PM
Dual battery Isolator Smiderman Generation 3 Pajero 2 23-01-14 10:07 PM
Dual Battery (Again)... DC/DC or Isolator?? Didge Generation 4-1 Pajero 26 29-08-12 08:29 PM
Dual Battery Isolator Brettm357 Electrical / Radios 9 19-02-10 04:23 PM


All times are GMT +10. The time now is 07:27 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.