Pajero 4WD Club of Victoria Public Forum Pajero 4WD Club of Victoria Public Forum

Go Back   Pajero 4WD Club of Victoria Public Forum > Vehicles > Pajero Sport > Pajero Sport QE 2015 - 2019

Pajero Sport QE 2015 - 2019 The Pajero Sport new to Oz

Reply
 
Thread Tools Display Modes
  #1  
Old 22-05-19
Gregmj Gregmj is offline
Junior Member
 
Join Date: Feb 2017
Location: Sydney
Posts: 11
Default fACTORY BRAKE CONTROLLER HARNESS

I have fitted the factory brake controller harness but I am not getting any power to the red wire that comes from the brake lights when brakes are applied. I have triple checked wiring to instructions and everything seems right. I have read on here that someone else had this problem and found something not connected at the rear near the trailer socket or in rear quarter near jack from the trailer wiring harness.
Anyone have any ideas? I'm all out.

Redarc tow pro elite
Factory trailer harness (fitted at dealer)
Factory brake harness.
Constant green flashing light on Redarc unit when trailer plugged in (low voltage)
Thanks.
Reply With Quote
  #2  
Old 23-05-19
DID Dash DID Dash is offline
Member
 
Join Date: Aug 2016
Location: Australia
Posts: 183
Default

Not sure if I am a great help, but a mate and I fitted his 18MY Pajero Sport with factory EBH and Redarc Towpro a few weeks back. First thing we did is confirm the dealer installed factory Towbar and Towbar Harness were operating properly by checking if all trailer lights were operational. They were. Can you be sure your Towbar Harness was operational before your EBH install? Then we carefully followed the factory EBH fitting instructions. We found them reasonably easy to follow, but small fingers, good eyesight and patients are required, particularity backing out the red/white wire at the junction box. Fortunately our install was successful. We found that the active calibration took quite a while which meant green/blue flashing for some time. I would try giving all the connectors a good wriggle, disconnect the engine bay harnesses, check the fuses, reconnect, take the car for a good drive with firm braking and accelerating to calibrate, then check the trailer pin for all functions. I have had my 17MY Pajero Sport / factory towbar and harness / factory EBH and Towpro for about a year and it has been faultless. I believe Redarc have a good tech help line (never used myself) but might be worth a try if all other options fail. Good luck.
__________________
17MY Pajero Sport, Factory Towbar, King Springs KCRS-23/Pedders 5899 Cones, 265/70R17 A/T's for the rough trips.
Reply With Quote
  #3  
Old 24-05-19
Gregmj Gregmj is offline
Junior Member
 
Join Date: Feb 2017
Location: Sydney
Posts: 11
Default

Thanks for that. Yes, towbar harness is working fine with all lights.
The problem seems to be a disconnect on the red/white wire somewhere near the back. I have checked connections from tow pro throughout kick panel harness and have a good connection. I have read that the red/white wire needs to be connected somewhere behind the back bumper during towbar harness installation, but it seems this was not done.
Reply With Quote
  #4  
Old 24-05-19
DID Dash DID Dash is offline
Member
 
Join Date: Aug 2016
Location: Australia
Posts: 183
Default

Bugga, mates car had factory towbar harness installed by dealer prior to delivery. I suppose they followed usual fitment routine. We had no need to play with wiring at the towbar plug, nor behind the the cargo trims. Only interface for ETB instal is the engine bay harness and kick trim harness. Hope you sort it.
__________________
17MY Pajero Sport, Factory Towbar, King Springs KCRS-23/Pedders 5899 Cones, 265/70R17 A/T's for the rough trips.
Reply With Quote
  #5  
Old 18-06-19
Pajsportwa Pajsportwa is offline
Junior Member
 
Join Date: Aug 2017
Location: Western Australia
Posts: 1
Default

Hi Greg did you solve the issue? I have the same problem and I have triple checked everything.
Reply With Quote
  #6  
Old 24-06-19
Gregmj Gregmj is offline
Junior Member
 
Join Date: Feb 2017
Location: Sydney
Posts: 11
Default

No, ended up just running cable from Redarc controller back to harness in rear left quarter cavity. Should have just done this in the first place and saved myself about 4 hours.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Genuine brake controller harness and Hayman Reece tow bar harness. Stinky Generation 4-4 Pajero 5 18-03-18 07:36 AM
How to tell if I have an electronic brake controller harness Weebok Electrical / Radios 9 19-06-16 09:09 AM
Help please!!! Electronic Brake Controller Harness not working 09VRXDiD Generation 4-2 Pajero 19 26-11-15 10:00 AM
Factory fitted wiring harness for brake controller IdRatherBe Generation 4-1 Pajero 2 19-02-15 10:51 PM
Brake controller harness how do you know if ones fitted? achjimmy Generation 4-2 Pajero 2 25-10-10 12:21 PM


All times are GMT +10. The time now is 11:00 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.