Pajero 4WD Club of Victoria Public Forum Pajero 4WD Club of Victoria Public Forum

Go Back   Pajero 4WD Club of Victoria Public Forum > Vehicles > Generation 4-2 Pajero

Generation 4-2 Pajero NT model 2009 - 2011

Reply
 
Thread Tools Display Modes
  #11  
Old 14-01-20
spot01 spot01 is online now
Valued Member
 
Join Date: Apr 2011
Location: Adelaide
Posts: 3,326
Default

Quote:
Originally Posted by Achilles View Post
Update: cleaned the corrosion with boiling water. Got the car to start again, but it still goes into limp mode. Seems to be as soon as it changes up from first gear
Did you remove & clean the inside of the terminal & the battery post with something like sandpaper, etc? It needs to be shiny in there!
__________________
Pajero NX MY16 GLS
Reply With Quote
  #12  
Old 14-01-20
craka craka is offline
Valued Member
 
Join Date: Jun 2009
Location: Newcastle (Newie)
Posts: 1,857
Default

So is it starting consistently now?

Do you have a OBDII scanning tool of any type, to see what codes are being generated?
__________________
NS SWB X 3.2DiD - Factory locker, Hella spotties, GME UHF, roof racks otherwise stock as a rock.

Retired: 1991 NH SWB 3.0L V6 5sp Manual, Mickey Thompson ATZs, GME UHF TX3200.
Wanting: Rocksliders, 2" lift, snorkel or perhaps I should wait and purchase a NS swb in 12months time.
Reply With Quote
  #13  
Old 14-01-20
Achilles Achilles is offline
Junior Member
 
Join Date: Jul 2019
Location: Brisbane
Posts: 21
Default

Quote:
Originally Posted by craka View Post
So is it starting consistently now?

Do you have a OBDII scanning tool of any type, to see what codes are being generated?
Yeah, I have an OBD mini tool that I've never used. But of course it won't connect to my phone now that I need it 😂 Light comes on, but not discoverable. It was a cheap ebay one, so that might be why.
Reply With Quote
  #14  
Old 14-01-20
craka craka is offline
Valued Member
 
Join Date: Jun 2009
Location: Newcastle (Newie)
Posts: 1,857
Default

That's a bugger. Just might give more of an indication of what is going on.
__________________
NS SWB X 3.2DiD - Factory locker, Hella spotties, GME UHF, roof racks otherwise stock as a rock.

Retired: 1991 NH SWB 3.0L V6 5sp Manual, Mickey Thompson ATZs, GME UHF TX3200.
Wanting: Rocksliders, 2" lift, snorkel or perhaps I should wait and purchase a NS swb in 12months time.
Reply With Quote
  #15  
Old 14-01-20
bgibo bgibo is offline
Junior Member
 
Join Date: Oct 2012
Location: melb
Posts: 37
Default Elec prob

Poss stater motor - had friend with similar
Reply With Quote
  #16  
Old 15-01-20
Achilles Achilles is offline
Junior Member
 
Join Date: Jul 2019
Location: Brisbane
Posts: 21
Default

Managed to get the OBD scanner working, and it shows 2 codes:

P0299 - turbocharger low boost
P0192 - fuel rail pressure sensor low input

I'm guessing with a bit of searching on the forum I should be able to figure this out
Reply With Quote
  #17  
Old 15-01-20
geopaj's Avatar
geopaj geopaj is offline
Valued Member
 
Join Date: Jul 2007
Location: Adelaide
Posts: 2,358
Default

Quote:
Originally Posted by Achilles View Post
Managed to get the OBD scanner working, and it shows 2 codes:

P0299 - turbocharger low boost
P0192 - fuel rail pressure sensor low input

I'm guessing with a bit of searching on the forum I should be able to figure this out
Did you also clear the codes? It’s important to clear them and see if they come back after you’ve ‘messed’ with something (ie after you cleaned the connections)
__________________
Silver NT VRX Di-D

| ARB bullbar | snorkel | Bushskinz guards | UltraGauge MX | 2" lift | airbags | Cooper AT3 LT's | Superwinch X9 | 80ltr diesel tank in rear seat well | 22ltr water tank | aux trans cooler | MM Lockup Mate | GME UHF | locker/TC mod | SPV EGR | rear LED work light | rhino platform | ARB awning | rear drawers ... & plenty of scratches

My Build Thread - HERE

Previously - NL Pajero (now owned by Forum member 'Gemster')
Reply With Quote
  #18  
Old 15-01-20
craka craka is offline
Valued Member
 
Join Date: Jun 2009
Location: Newcastle (Newie)
Posts: 1,857
Default

Quote:
Originally Posted by geopaj View Post
Did you also clear the codes? It’s important to clear them and see if they come back after you’ve ‘messed’ with something (ie after you cleaned the connections)
Do what Geopaj said, if they come back, check your vacuum hoses.
__________________
NS SWB X 3.2DiD - Factory locker, Hella spotties, GME UHF, roof racks otherwise stock as a rock.

Retired: 1991 NH SWB 3.0L V6 5sp Manual, Mickey Thompson ATZs, GME UHF TX3200.
Wanting: Rocksliders, 2" lift, snorkel or perhaps I should wait and purchase a NS swb in 12months time.
Reply With Quote
  #19  
Old 16-01-20
Achilles Achilles is offline
Junior Member
 
Join Date: Jul 2019
Location: Brisbane
Posts: 21
Default

Quote:
Originally Posted by geopaj View Post
Did you also clear the codes? It’s important to clear them and see if they come back after you’ve ‘messed’ with something (ie after you cleaned the connections)
Cleaned up the ground connections and battery terminals with a wire brush and electrical contact cleaner, and then cleared the codes. Took her for a drive and it ran fine for about 1km until I gunned it to test the turbo - went back into limp mode at that point. When I checked the codes again, the turbo pressure code had cleared. Now I just have P0192 'fuel rail pressure sensor low input'.

Took the paj to the beach the other day - could this all be caused by corrosion from salt water?

Ps: I appreciate all the help guys!

Last edited by Achilles; 16-01-20 at 05:50 PM.
Reply With Quote
  #20  
Old 16-01-20
geopaj's Avatar
geopaj geopaj is offline
Valued Member
 
Join Date: Jul 2007
Location: Adelaide
Posts: 2,358
Default

Quote:
Originally Posted by Achilles View Post
Cleaned up the ground connections and battery terminals with a wire brush and electrical contact cleaner, and then cleared the codes. Took her for a drive and it ran fine for about 1km until I gunned it to test the turbo - went back into limp mode at that point. When I checked the codes again, the turbo pressure code had cleared. Now I just have P0192 'fuel rail pressure sensor low input'.

Took the paj to the beach the other day - could this all be caused by corrosion from salt water?

Ps: I appreciate all the help guys!
That’s great progress!

I’ve personally had this code and worked through the fault finding procedure.

This will help - http://faq.out-club.ru/download/paje...9/index_M1.htm
(Go to Diesel Fuel, Trouble Shooting, Inspection chart for trouble codes, then look up P0192)

Do you have a Scangauge or similar than can display real time fuel pressure?

With mine, I discovered that, even though the engine was running, fuel rail press was 0psi (but the engine can’t run with 0psi so I deducted that was either a problem with the actual sensor, or the wiring loom). One mine, I checked the continuity of the loom and it was fine. With the engine running I then lightly tapped the fuel rail pressure sensor with a spanner. Immediately I got an appropriate fuel pressure reading but only for a short while. I then deduced that the actual sensor had failed and replaced the sensor which solved my problem. I think the sensor was about $100-$150 (aftermarket) from Hi Tech Diesel and I replaced it myself.

That was 23,000km ago and I haven’t had a problem since however I would strongly suggest working through the diagnosis process because you may have another problem causing the code.

ps - I would say it’s unrelated to your beach trip.
__________________
Silver NT VRX Di-D

| ARB bullbar | snorkel | Bushskinz guards | UltraGauge MX | 2" lift | airbags | Cooper AT3 LT's | Superwinch X9 | 80ltr diesel tank in rear seat well | 22ltr water tank | aux trans cooler | MM Lockup Mate | GME UHF | locker/TC mod | SPV EGR | rear LED work light | rhino platform | ARB awning | rear drawers ... & plenty of scratches

My Build Thread - HERE

Previously - NL Pajero (now owned by Forum member 'Gemster')
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2 stage thermostat? haz77 Generation 3 Pajero 6 25-06-18 09:39 PM
NW Pajero Plarinum Setup & Fit-out Stage 1 d.i.wirtz Do It Yourself Projects 91 16-11-15 02:12 PM
Pajero is dying looking at buying a Navara Grungle1 Generation 2 Pajero 26 22-03-15 07:24 AM
NH pajero 3.olt petrol dying in water murphs-diesel Electrical / Radios 5 28-08-13 10:16 PM
98 NL GLS ... Stage 1 : The planning xntrek Do It Yourself Projects 21 13-05-13 05:05 PM


All times are GMT +10. The time now is 05:07 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.