Pajero 4WD Club of Victoria Public Forum Pajero 4WD Club of Victoria Public Forum

Go Back   Pajero 4WD Club of Victoria Public Forum > Vehicles > Generation 4-2 Pajero

Generation 4-2 Pajero NT model 2009 - 2011

Reply
 
Thread Tools Display Modes
  #1  
Old 11-01-20
vanastasis vanastasis is offline
Junior Member
 
Join Date: May 2013
Location: Wollongong
Posts: 29
Default MMCS A.04 No Sound

Hi All,

My head unit is no longer working.

while driving & listening to music it displayed a loading bar and restarted.

upon restarting everything does not work except fot the gps. ( maps routing etc works, no sound )

no sound of any kind ( no beep, bluetooth voice calls don't work )
steering wheel controls not working ( radio related, cruise works )

turned car off then back on, you can hear the amp is working due to the sound a speaker sounds
when an amp turns on but nothing else. ( where is the amp ? )

has anyone had issues like this before ?

thank you
Bill


p.s. stuck in map / gps mode, can't view anything else
Reply With Quote
  #2  
Old 12-01-20
vanastasis vanastasis is offline
Junior Member
 
Join Date: May 2013
Location: Wollongong
Posts: 29
Default

Some good news.

the radio started working.

well in saying that only the radio worked, the channel it was previously on, steering wheel controls
still not working, all other functions of head unit still not working.

i have also noticed, when the head unit has its fit, it affects my heater/aircon settings.

don't know if its related.

but got some sound in the car, yet i can't control anything of it. lol

- Bill
Reply With Quote
  #3  
Old 14-01-20
vanastasis vanastasis is offline
Junior Member
 
Join Date: May 2013
Location: Wollongong
Posts: 29
Default

no one ?
Reply With Quote
  #4  
Old 15-01-20
vanastasis vanastasis is offline
Junior Member
 
Join Date: May 2013
Location: Wollongong
Posts: 29
Default M.U.T.-III Scanner

Hi,

Anyone in the Wollongong area with a MUT III Scanner please.

Need to scan my head unit / can bus for errors

thank you
Bill
Reply With Quote
  #5  
Old 16-01-20
drgtr drgtr is offline
Member
 
Join Date: Sep 2019
Location: Rosemeadow
Posts: 145
Default

Quote:
Originally Posted by vanastasis View Post
Hi All,

My head unit is no longer working.

while driving & listening to music it displayed a loading bar and restarted.

upon restarting everything does not work except fot the gps. ( maps routing etc works, no sound )

no sound of any kind ( no beep, bluetooth voice calls don't work )
steering wheel controls not working ( radio related, cruise works )

turned car off then back on, you can hear the amp is working due to the sound a speaker sounds
when an amp turns on but nothing else. ( where is the amp ? )

has anyone had issues like this before ?

thank you
Bill


p.s. stuck in map / gps mode, can't view anything else

all speakers go to the amp
then from amp to unit

there is a "30mp" amp fusible link fuse in the fuse box in the engine bay.

Check that
probably blown
Reply With Quote
  #6  
Old 16-01-20
vanastasis vanastasis is offline
Junior Member
 
Join Date: May 2013
Location: Wollongong
Posts: 29
Default

Quote:
Originally Posted by drgtr View Post
all speakers go to the amp
then from amp to unit

there is a "30mp" amp fusible link fuse in the fuse box in the engine bay.

Check that
probably blown

Hi,

Thank you, fuse already checked and ok.

had scanner on it, and there seems to be an issue with canbus somewhere
probably in the MMCS head unit
Reply With Quote
  #7  
Old 29-03-20
kanchigo kanchigo is offline
Junior Member
 
Join Date: Mar 2020
Location: Rockdale, nsw
Posts: 8
Default

Quote:
Originally Posted by vanastasis View Post
Hi,

Thank you, fuse already checked and ok.

had scanner on it, and there seems to be an issue with canbus somewhere
probably in the MMCS head unit
I have a spare mmcs head unit with working conditions came of 2010 NT for sale $100, or head unit 9 inches came of 2015 asx with apple car play fit perfectly for sale too
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MMCS IPOD Connector on back of MMCS Head Unit mr_bosman Do It Yourself Projects 11 11-03-15 07:20 PM
Eco method firewall sound proof. Sound proof Level 80% phiew Generation 4-1 Pajero 17 03-05-14 04:04 PM
No SOund from sound system newtopaj Electrical / Radios 5 01-11-13 09:10 PM
What's that sound? hhaannkkyy Generation 4-1 Pajero 7 01-03-13 10:17 AM
tik .. tik sound ! lugzy Generation 2 Pajero 7 09-09-10 04:16 PM


All times are GMT +10. The time now is 10:13 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.