Pajero 4WD Club of Victoria Public Forum Pajero 4WD Club of Victoria Public Forum

Go Back   Pajero 4WD Club of Victoria Public Forum > Vehicles > Generation 4-1 Pajero

Generation 4-1 Pajero NS Model 2006 - 2009

Reply
 
Thread Tools Display Modes
  #1  
Old 14-09-17
draganlada draganlada is offline
Member
 
Join Date: Dec 2010
Location: sydney
Posts: 169
Default EGR again

HI guys
I've just picked up my NS did from local mechanic who diagnosed faulty EGR valve (which I already knew thanks to this great forum) and,what stunned me,he said EGR cooler needs to be replaced with new one due to clogging and insufficient flow I have never heard of such case before,not on this forum.
Did anyone here have to clean or replace their EGR cooler,what are your opinion on this one?
BTW my pajero is stock standard,no mods to EGR or DPF
Cheers !

P.S. Quote is $ 2000- using genuine parts,EGR cooler + valve
Reply With Quote
  #2  
Old 14-09-17
aussieintas's Avatar
aussieintas aussieintas is offline
Valued Member
 
Join Date: Feb 2013
Location: Sorell, Tasmania
Posts: 765
Default

For a few cents you can block the egr with a resistor and be done with it Dont know if you've seen the thread below, its what i did to mine once I cleaned intake.

https://www2.pajeroclub.com.au/forum...ad.php?t=46390
__________________
2008 NS X SWB DiD auto in cool silver, Pirelli Scorpion ATR's, nudge bar with led light bar

Previously
88 NF SWB 2.6 manual
92 NH LWB 3.0 auto
92 NH J-Top 2.5 manual
95 NJ SWB 3.0 auto
99 Cruiser 4.5 manual with all the fruit

Last edited by aussieintas; 14-09-17 at 07:17 PM. Reason: Further info
Reply With Quote
  #3  
Old 14-09-17
Seigried Seigried is offline
Member
 
Join Date: Apr 2016
Location: brisbane
Posts: 210
Default

I have seen a few threads on the south african and uk forums about failed egr coolers. So it does happen thought from what I have read its uncommon here in aus.

Sent from my SM-G900I using Tapatalk
Reply With Quote
  #4  
Old 17-09-17
draganlada draganlada is offline
Member
 
Join Date: Dec 2010
Location: sydney
Posts: 169
Default

Decided to save few bucks and took EGR cooler off and cleaned it myself.Wanted to finish the job this weekend and went to dealer and bought EGR valve for $ 550- because did not have time to wait for part of eBay. Put everything back together and got myself Xtool dongle to erase fault code and to monitor EGR operation.Everything worked fine for about 70-ish km of city driving till scanner started shoving Commanded EGR 0.00%Everything else is fine no fault codes showing or pending only EGR does not move from zero.Engine shuts down normally,no run on for 1 sec like before with faulty EGR valve.
Is it possible that there is something other faulty what "kills" EGR solenoids on my carHelp please

P.S.Please dont tell me to do $ 1- resistor mod ,that will not fix my cars problem and I like to keep it standard and road worthy.
Reply With Quote
  #5  
Old 17-09-17
Ian H Ian H is offline
Valued Member
 
Join Date: May 2015
Location: melbourne
Posts: 764
Default

It's just a thought but is it possible that the cooler is still bung and not cooling the exhaust gas enough, so the EGR shuts down to prevent the extra hot gasses going back in?
__________________
2015 NX GLS, Factory alloy bar, Ridepro springs & Rox Shocks, dual batteries with Redarc DC/DC, LRA 58L tank, Safari snorkel, Boo's bash plates (full set), 17" steels with Toyo OPAT AT2's, Titan drawers with slide, TPMS, Uniden UH8080S. Infinity caravan and a TVan Firetail.
Reply With Quote
  #6  
Old 17-09-17
draganlada draganlada is offline
Member
 
Join Date: Dec 2010
Location: sydney
Posts: 169
Default

Thanks for reply Ian
After I have cleaned inside of cooler looked nice clean and shiny like new,I pumped water through it and it flew really good.
On whole EGR system,the cooler,the connection pipes and the valve,I did not see any sensor which can measure temperature,pressure,or flow of exhaust gases

I do not know if new EGR valve has to be initialized,relearned or something like that,with MUT lll
Reply With Quote
  #7  
Old 17-09-17
aussieintas's Avatar
aussieintas aussieintas is offline
Valued Member
 
Join Date: Feb 2013
Location: Sorell, Tasmania
Posts: 765
Default

Just had a look at the online workshop manual, doesnt say anything about a relearn. Link below, section 17.

http://faq.out-club.ru/download/paje...e/index_M1.htm
__________________
2008 NS X SWB DiD auto in cool silver, Pirelli Scorpion ATR's, nudge bar with led light bar

Previously
88 NF SWB 2.6 manual
92 NH LWB 3.0 auto
92 NH J-Top 2.5 manual
95 NJ SWB 3.0 auto
99 Cruiser 4.5 manual with all the fruit
Reply With Quote
  #8  
Old 17-09-17
draganlada draganlada is offline
Member
 
Join Date: Dec 2010
Location: sydney
Posts: 169
Default

thanks aussieintas
Reply With Quote
  #9  
Old 19-09-17
draganlada draganlada is offline
Member
 
Join Date: Dec 2010
Location: sydney
Posts: 169
Default

Good news,I've found out why EGR was shoving 0.00%
Started the car,scanner was shoving EGR 0.00% but CAT temperature went over 400'C in just few hundred meters after startup (normally sits around 300'C all the time ) and started rising towards 600 very quickly.That put smile beck on my face,I knew what it meant,DPF started its burn process and that is why EGR was shut ,as soon as CAT temperature came back to 300-ish,EGR started to show its normal figures
I remembered reading somewhere on this forum EGR valve is shut during DPF burn cycle and this prove it correct.
Now to find some honest mechanic to clean my inlet manifold and doesn't want an arm and a leg in return
Reply With Quote
  #10  
Old 19-09-17
aussieintas's Avatar
aussieintas aussieintas is offline
Valued Member
 
Join Date: Feb 2013
Location: Sorell, Tasmania
Posts: 765
Default

Well thats a bit of good news bud.
__________________
2008 NS X SWB DiD auto in cool silver, Pirelli Scorpion ATR's, nudge bar with led light bar

Previously
88 NF SWB 2.6 manual
92 NH LWB 3.0 auto
92 NH J-Top 2.5 manual
95 NJ SWB 3.0 auto
99 Cruiser 4.5 manual with all the fruit
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time now is 07:15 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.